[ Home | Liste | F.A.Q. | Risorse | Cerca... ]


[ Data: precedente | successivo | indice ] [ Argomento: precedente | successivo | indice ]


Archivio: openbsd@sikurezza.org
Soggetto: Re: Problemi con Mysql
Mittente: Paolo Bianchi
Data: 14 Mar 2002 18:55:06 -0000
Io ho un problema simile, solo che cambiando la sintassi non funziona lo
stesso.
Il mysql server funziona solo appena installato e poi non va pił, se provo
ad avviarlo dopo aver riavviato la macchina mi dice:

-----
# /usr/local/bin/safe_mysqld &
[1] 6763
# Starting mysqld daemon with databases from /var/mysql
020312 14:39:04  mysqld ended


[1] + Done                 /usr/local/bin/safe_mysqld
-----

Non capisco perchč non vuole andare...

Ciao!

- Paolino

----- Original Message -----
From: "Francesco" <kfrancesco@baronerosso.net>
To: <openbsd@sikurezza.org>
Sent: Wednesday, February 06, 2002 8:49 PM
Subject: Problemi con Mysql


> Ho un problema con il Mysql, in pratica il servizio funziona unicamente
> dopo aver installato i package, appena riavvio della macchina non parte
> piu'!!!
>
> L'openbsd e' la versione 3.0 e i pacchetti installati subito dopo
> l'istallazione sono:
>
> Apache apache_1.3.22.tar (installato a mano, con il classico make)
>
> PHP php4-4.0.6p1.tgz (installato con pkg_add)
>
> Mysql mysql-server-3.23.42.tgz (installato con pkg_add) + le dipendenze
> mysql-client-3.23.42.tgz e pth-1.4.0p1.tgz (che si e' installato da
> solo)
>
> Dopo l'installazione il tutto funziona fino a quando non riavvio, cmq se
> rimuovo i package del mysql e lo reinstallo il tutto funziona,
> naturalmente fino a quando non riavvio di nuovo.
>
> Il messaggio di errore quando lancio la stringa per far partire il mysql
> e':
>
> #/usr/local/bin/safe_mysqld &
>
> [1] 28443
> # /usr/libexec/ld.so: my_print_defaults: libpthread.so.14.20: No such
> file or directory
> Starting mysqld daemon with databases from /var/mysql
> 020206 20:24:56  mysqld ended
> [1] + Done                 /usr/local/bin/safe_mysqld
> #
>
> Dal messaggio mi pare di capire che non trovi i file ld.so,
> my_print_defaults e libpthread.so.14.20 nella dir /usr/libexec, ed
> infatti esiste solo il file ld.so (cmq mettendo gli altri non cambia
> nulla)
>
> Non vorrei che ci fosse qualche problema nel settare le dir delle
> librerie, io le ho aggiunte in questo modo nel rc.conf
>
> shlib_dirs=/usr/local/lib/pth   # extra directories for PTh
> shlib_dirs=/usr/local/lib/mysql # extra directories for ldconfig
>
> Non so se la sintassi sia quella giusta perche' non ho trovato nulla al
> riguardo.
>
>
> Saluti Francesco Kaitner
> WebMaster di: http://www.baronerosso.net
>
>
> ________________________________________________________
> http://www.sikurezza.org - Italian Security Mailing List


________________________________________________________
http://www.sikurezza.org - Italian Security Mailing List




[ Home | Liste | F.A.Q. | Risorse | Cerca... ]

www.sikurezza.org - Italian Security Mailing List
(c) 1999-2005